Results 1 to 3 of 3

Thread: Pastel batches: Update mode not available

  1. #1
    New Member
    Join Date
    Oct 2019
    Location
    Cape Town
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Question Pastel batches: Update mode not available

    After upgrading to Pastel Partner V19 and Pervasive V13, users regularly get the message "Update mode not available. Another user is busy updating batches", even though no other batches are being updated. Definitely something to do with Pervasive because after downgrading to V10 the problem disappears. Happens on both Pastel Partner V18 and V19.
    Anybody have the same issue, or a suggestion to fix?

  2. #2
    Bronze Member
    Join Date
    Aug 2018
    Location
    Johannesburg
    Posts
    124
    Thanks
    0
    Thanked 26 Times in 23 Posts
    Hi Terry

    Check your Anti Virus and local machine firewall. You may find that you have exclusions for PVSW10 set, but nothing for PVSW13 processes, and it is scanning files during the update process and causing a lockdown.

    You can try changing the PVSW memory usage as well. Start - Run - PCC. Select the option to "Configure local Engine" Under the memory usage, tick the "Back to minimal state if inactive" setting. You can also decrease the Minimal State Delay - think the default is 300000 milliseconds, or 5 minutes. Decrease to 60000 and apply. You will need to do this on each workstation. (assuming you are running PVSW workgroup, not client server).

    After that... you need to start doing some digging, while the users are getting the message. Open the PVSW Monitor on the gateway machine. Under the microkernel option, resource usage will show you if there are any locked files under the current column. If there are, you will need to go to microkernel active files, and go through the list (just arrow down file by file) until you find which files are locked. (the Accuser file will always be locked if someone is logged in) but the other files might give us a clue as to what is happening. As an example, if you edit a customer then try update a batch while the edit screen is open, you will have a record lock on the customer masterfile (accmasd), but be told "you need to close all edit screens before you can update". If a second user is editing customers while you are trying to update, you might get the update mode not available message you are referring to.

  3. #3
    New Member
    Join Date
    Oct 2019
    Location
    Cape Town
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Kevin, Thanks for the pointers, I will look into those as suggested. What bothers me is that I have 20 users on this site, running Pastel V18, who, directly after we upgraded PSQL to V13, suddenly started having this issue, as well as odd other complaints of Pastel "freezing" from time to time. As soon as we reverted to V10, all problems disappeared. Then I have another site with only 2 users on Pastel V19, who now also experience this issue since upgrading to PVSW13. I can't find any guidelines on this, but what is the "normal" max number of locks to expect on acchistl.dat? I have seen upward of 100 on one user supposedly just capturing GRNs.

Similar Threads

  1. Pastel Open Batches
    By yowho in forum Accounting Forum
    Replies: 3
    Last Post: 06-May-19, 04:13 PM
  2. HELP!! Missing batches - Pastel V18
    By Kevin Maeka in forum Accounting Forum
    Replies: 0
    Last Post: 06-Dec-18, 03:35 PM
  3. [Question] Pastel GRN batches not updating
    By Coolblue in forum Accounting Forum
    Replies: 0
    Last Post: 03-Feb-18, 05:43 PM
  4. [Question] Pastel Partner Design mode
    By Tans in forum Accounting Forum
    Replies: 1
    Last Post: 04-May-17, 08:30 AM
  5. Replies: 1
    Last Post: 10-Dec-12, 11:37 AM

Tags for this Thread

Did you like this article? Share it with your favourite social network.

Did you like this article? Share it with your favourite social network.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •